Problem with my Aspire Speeder Mod.

Vaping Mods Problem with my Aspire Speeder Mod.

This topic contains 3 replies, has 2 voices, and was last updated by  Steve 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #8489

    Scorch666
    Participant

    My mod will just randomly fire by itself. I’ve tried all firmware updates, still not fixed. So I’ve reverted back to the original firmware. Still useless.
    As far as I can see the batteries are fine, no little niks.

    Anyone else have this problem?

    Please help.

    #9200

    Steve
    Moderator

    Is there anything causing the fire button to get stuck? I would try to clean around the fire button with some Isopropyl Alcohol. If nothing is causing the fire button to get stuck, then you have a defective mod. I would contact Aspire, I am not sure how old the mod is as they generally come with a 90 day warranty, so if it is out of warranty, not sure what Aspire will do for you. I still would contact them, could just be a defective button and they might replace it for you or you could possibly take it to a vape shop and see if they work on mods and can look at the button. Aspire would be the first place I go though.

    #9408

    Scorch666
    Participant

    Thanks for your reply.
    I must have cleaned it a dozzon times. So yeah it must be buggered. I’ve had it for over a year now, so not sure if i’ll bother contacting them. Tbh I haven’t cleaned it with Isopropyl Alcohol, so will try that. ( Is that the same stuff that cleans crap off CPU’s in computers?) If so i’ll use that.
    I’ll let you know how I get on.
    Cheers.

    #9410

    Steve
    Moderator

    I hope you get it all sorted out, probably just a bad button inside the mod.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.